NSX Manager Not accessible and we see alert "Services are down because software integrity check failed. Please refer troubleshooting guide." on the NSX Manager VM Console
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NSX Manager Not accessible and we see alert "Services are down because software integrity check failed. Please refer troubleshooting guide." on the NSX Manager VM Console

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Article ID: 378639

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Updated On:

Products

VMware NSX

Issue/Introduction

NSX Manager is not accessible through UI/SSH
We see below Error on the NSX Manager VM Console in vCenter after login
"Services are down because software integrity check failed. Please refer troubleshooting guide."

Environment

VMware NSX version prior to 3.2.4 and 4.2

Cause

sw integrity checker failure only impact at the boot time and it bring down network interfaces and other services on the NSX VM on failure.

/image/.sw_integrity_check_failed is present on the affected Manager

Resolution

Issue is fixed in VMWare NSX version 4.2.0 and VMware NSX-T Datacenter version 3.2.4

Workaround

Deploying an another appliance is a only permanent solution for this issue once this issue is encountered.
To redeploy a manager node, primarily we need the UI access. So please remove the file ".sw_integrity_check_failed" under /image folder and reboot the appliance. This will bypass the sw integrity check.
Once the UI is accessible, proceed to redeploy the manager.