NSX Manager inaccessible, Error: "Services are down because software integrity check failed. Please refer troubleshooting guide."
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Article ID: 378639
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Updated On:
Products
VMware NSX
Issue/Introduction
NSX Manager is not accessible through UI/SSH
We see below Error on the NSX Manager VM Console in vCenter after login: "Services are down because software integrity check failed. Please refer troubleshooting guide."
Environment
VMware NSX-T Datacenter 3.x.x
VMware NSX 4.x
Cause
sw integrity checker failure only impact at the boot time and it bring down network interfaces and other services on the NSX virtual machine on failure.
/image/.sw_integrity_check_failed is present on the affected Manager
Resolution
Issue is fixed in VMware NSX version 4.2.x and VMware NSX-T Datacenter version 3.2.4
Workaround:
Remove the file ".sw_integrity_check_failed" and ".sw_integrity_check" under /image folder.
Reboot the appliance. This will bypass the sw integrity check.
Primarily we need the UI access if its one node deployment. Once the UI is accessible, proceed to redeploy the manager.
Note: Deploying a new appliance is the only permanent solution once this issue occurs.