Thumbprint is not a valid SHA-1 thumbprint - Adapter instance in Warning State Due to Invalid Thumbprint Error in Aria Operations
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Thumbprint is not a valid SHA-1 thumbprint - Adapter instance in Warning State Due to Invalid Thumbprint Error in Aria Operations

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Article ID: 378615

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Updated On:

Products

VMware Aria Suite

Issue/Introduction

  • Adapter instance for VMware Aria Operations is showing a Warning state. Upon validation connection, the following error was observed:
    • Thumbprint is not a valid SHA-1 thumbprint: xxxxxxxxxxxxxxxxxxxxxxxx

  • The issue can occur for any management packs though common affected management packs are The Dell EMC VxRail Management Pack (MP) and also VMware Aria Operations Management Pack for Storage Devices 
  • This issue maybe noticed after upgrading Aria Operations to a later version

Environment

Aria Operations 8.18.x

Cause

The cause of the adapter instance in Warning state is an outdated version of the management pack. Outdated versions might not be compatible with the latest features and security protocols of Aria Operations. Additionally, the error message "starting Thumbprint is not a valid SHA-1 thumbprint" suggests a potential security certificate mismatch between the MP and Aria Operations

Resolution

  1. Verify the MP Version: Check the current version used by navigating to Administration > Integrations > Repository 
  2. Confirm compatibility of the MP with Aria Operations version by entering in the details of the Management Pack and Aria Operations version into the Product Interoperability Matrix 
  3. Download and Upgrade MP: If the version of the MP is not compatible, download the latest compatible version using the VMware Cloud Marketplace link . Once downloaded, follow the upgrade instructions for your specific Aria Operations version
  4. Validate Connection: After upgrading the management pack, re-validate the connection within Aria Operations. The status should change to "OK" if the upgrade was successful

Additional Information

  • Upgrading software to the latest versions is crucial for maintaining compatibility, security, and optimal performance.
  • If the issue persists after following these steps, and the affected Management pack is a third party management please contact their support for further assistance.