ARD 3.4 will not launch after upgrade
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ARD 3.4 will not launch after upgrade

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Article ID: 378531

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Updated On:

Products

CA Agile Requirements Designer

Issue/Introduction

ARD is not launching after clicking on the shortcut. It appears to be running in the background however the GUI is not visible.  An uninstall and re-install has been performed however the issue still exists.

Note, v3.2.5 was uninstalled and 3.4 installed.

When launching directly from a CMD window with the "AgileDesigner.exe " , same issue happened. 

Environment

ARD 3.4

Cause

Based on the investigation we saw the "configFile" or "automationConfigFile"  was manually modified in v3.2.5

Upgrade to 3.4 has not fixed the issue;  Registry keys are not cleared when ARD is reinstalled and same configuration files were used.

The same code is used in newer ARD version to read same corrupted configuration files and issue persisted.

Run the following commands in power shell to see the location of the modified config file its using while loading: 

Get-ItemPropertyValue -Path 'HKCU:\SOFTWARE\CA Technologies\AgileDesigner' -Name configFile
Get-ItemPropertyValue -Path 'HKCU:\SOFTWARE\CA Technologies\AgileDesigner' -Name automationConfigFile

Resolution

As a workaround, open PowerShell  and run these commands.  This will edit the Registry entries temporarily and allow ARD to load. 


Set-ItemProperty -Path 'HKCU:\SOFTWARE\CA Technologies\AgileDesigner' -Name configFile -Value ""
Set-ItemProperty -Path 'HKCU:\SOFTWARE\CA Technologies\AgileDesigner' -Name automationConfigFile -Value ""


The  default Configfile and AutomationConfig files will be used. 


 

Additional Information

Note *** If you face this issue once the files are corrupted, please do the above steps for versions up to v3.5. 

We will fix the config loading issue in v3.6.  Corrupted config will not be loaded.