Unable to login to the vCloud Usage Meter VAMI
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Unable to login to the vCloud Usage Meter VAMI

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Article ID: 378482

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Updated On:

Products

VMware Usage Meter

Issue/Introduction

  • After login Usage Meter VAMI for a long time, logout may cause cap-appliance-management.service to stop in rare cases.

  • cap-appliance-management.service is stopped and login to the Usage Meter VAMI fails with the following error:

    Unable to Login

  • In the log file at cap-appliance-management.service.log included in the log bundle of Usage Meter, you see entries similar to:

    fatal error: concurrent map read and map write

    Note: If this issue occurs, you can still login to the Usage Meter Web interface and other services are not affected.

Environment

Usage Meter 4.8
Usage Meter 9.0

Cause

This is due to a cache synchronization issue in the CAP Appliance Management Session Handler of the Common Appliance Platform (CAP) used by Usage Meter.

Resolution

Restart the CAP Appliance Management service.

  1. Connect through SSH to Usage Meter as usagemeter user.

  2. Switch to the root user.

    su

  3. Restart cap-appliance-management.service using below command:

    systemctl restart cap-appliance-management.service

    Note: Restarting the CAP Appliance Management service does not affect the operation of Usage Meter.

Additional Information