Uploading a product tile using Ops Manager UI returns Internal Server Error
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Uploading a product tile using Ops Manager UI returns Internal Server Error

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Article ID: 378463

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Updated On:

Products

Ops Manager

Issue/Introduction

When uploading a large product tile using Ops Manager UI, it fails with 500 - Internal Server Error.

 

Looking at the Ops Manager VM logs, it shows the following error:

 

 
 
[24/Sep/2024:03:27:40 +0000] "POST /product_adds HTTP/1.1" 500 32 "https://opsman.example.site.com/" "Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/129.0.0.0 Safari/537.36"

 
 
2024/03/02 04:01:54 [crit] 1484#1484: *1 connect() to unix:/tmp/tempest-web.sock failed (2: No such file or directory) while connecting to upstream, client: 10.1.1.2, server: , request: "GET /api/v0/info HTTP/1.1", upstream: "http://unix:/tmp/tempest-web.sock:/api/v0/info", host: "opsman.example.site.com"

Environment

NA

Cause

Usually, the 500 - Internal Server Error is a result of the Ops Manage VM not having enough free disk space for file upload that cause the nginx server to crashed.

Login to Ops Manager VM, we can see /dev/sda2 is running out of disk space at 100% used:

$ df -h

Filesystem      Size  Used Avail Use% Mounted on
tmpfs           794M   81M  713M  11% /run
/dev/sda2    158G   157G  2G  100% /
tmpfs           3.9G     0  3.9G   0% /dev/shm
tmpfs           5.0M     0  5.0M   0% /run/lock
tmpfs           4.0M     0  4.0M   0% /sys/fs/cgroup
tmpfs           3.9G     0  3.9G   0% /run/qemu
/dev/sda1        48M  5.7M   43M  12% /boot/efi
tmpfs           794M     0  794M   0% /run/user/1002

Resolution

We need make sure the OpsMan VM has enough available free space to upload and extract the product tile by scaling up the OpsMan VM disk capacity to resolve the issue.