Error while comparing PPM and DWH versions - During Upgrade precheck
search cancel

Error while comparing PPM and DWH versions - During Upgrade precheck

book

Article ID: 378303

calendar_today

Updated On:

Products

Clarity PPM On Premise Clarity PPM SaaS

Issue/Introduction

When doing Clarity Upgrade precheck with checkinstall the below error is thrown: 

check-db-dwh-sync.xml ERROR

Error while comparing PPM and DWH versions. Check the checkinstall.log for before you continue.

 <result name="check-db-dwh-sync.xml" value="ERROR">
    <resultinfo>Error while comparing PPM and DWH versions. Check the checkinstall.log for before you continue.</resultinfo>
  </result>

Environment

All Supported Clarity Releases 

Cause

The Clarity database version does not match the DWH database version. This may be a missed refresh or rollback

Resolution

Note: For lower environments, on refreshes: If the Clarity database refresh in a lower environment has been done a long time ago and you have added more fields in DWH in PROD that are no longer on lower environments this may cause failures. We recommend to perform the refresh together for PPM and DWH database to avoid Load DWH job failures (or use a blank DWH restore)