Identity Manager does not start and get the error: LDAP response read timed out, timeout used: 3000 ms
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Identity Manager does not start and get the error: LDAP response read timed out, timeout used: 3000 ms

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Article ID: 378275

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Updated On:

Products

CA Identity Suite CA Identity Manager

Issue/Introduction

While trying to start Identity Manager the following error message is displayed and the Identity Manager does not start

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INFO [ims.Main] (ServerService Thread Pool -- 101) * Startup Step 29 : Attempting to start environments
INFO [ims.Main] (ServerService Thread Pool -- 101) * Starting environment: identityEnv
INFO [com.workpoint.server.DbVerifier] (Timer-5) Workpoint DSN 'WPDS' using database version '4.40'.
WARN [ims.llsdk.etrustadmindirectory] (pool-12-thread-11) Not setting tenant key for environment identityEnv
ERROR [ims.llsdk.directory.jndi] (ServerService Thread Pool -- 101) LDAP response read timed out, timeout used: 3000 ms.
WARN [ims.tmt.EnvironmentService] (ServerService Thread Pool -- 101) * Failed to start environment: identityEnv

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Environment

Identity Manager 14.x (Virtual Appliance)

Cause

This error is related to the Java JDK as described in the link below

com.sun.jndi.ldap.LdapClient overrides readTimeout with connectionTimeout

 

Resolution

Run the stop_im and deleteIDMJMSqueue, if after that the error persists starting the Identity Manager, try the following:

 

As described in the link above, try to set both parameter in the jvm-arg.conf file.

 

Set both parameter "com.sun.jndi.ldap.connect.timeout" and "com.sun.jndi.ldap.read.timeout" to the same value.

- Edit the "/opt/CA/VirtualAppliance/custom/IdentityManager/jvm-args.conf" file

- Check if one of the following parameters are already set, usually the "-Dcom.sun.jndi.ldap.read.timeout" is set in the file, if not configure both or the missing one

- Append the parameters below in the end of the line of the jvm-args.conf file

       -Dcom.sun.jndi.ldap.connect.timeout=600000 -Dcom.sun.jndi.ldap.read.timeout=600000 

- Save the file and start the Identity Manager

 

If the problem still persists, please, open a Support case.