Application error when trying to create or access a rule that disarms attachments
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Application error when trying to create or access a rule that disarms attachments

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Article ID: 378210

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Updated On:

Products

Messaging Gateway

Issue/Introduction

You are trying to create an Email Malware rule with the "Disarm attachment(s)" action and have unchecked the "Annotate message if attachment(s) cannot be Disarmed" option. When trying to save the rule, an Application Error is encountered. If the rule manages to save, then subsequent attempts to access the rule also result in Application Errors.

The Control Center log, BrightmailLog.log, contains the following:

 

Sep 30 2024 08:37:13 [https-jsse-nio-443-exec-8] [ActionServlet] ERROR - null
java.lang.NullPointerException
        at com.symantec.smg.controlcenter.messagefiltering.policy.FilterPolicyManager.convertToScannerAction(FilterPolicyManager.java:2067)
        at com.symantec.smg.controlcenter.messagefiltering.policy.FilterPolicyManager.addPolicyActions(FilterPolicyManager.java:1013)
        at com.symantec.smg.controlcenter.messagefiltering.policy.FilterPolicyManager.toFilterPolicy(FilterPolicyManager.java:1241)
        at com.symantec.smg.controlcenter.messagefiltering.virus.VirusPolicyManager.toFilterPolicy(VirusPolicyManager.java:277)
        at com.symantec.smg.controlcenter.messagefiltering.policy.FilterPolicyManager.updatePolicy(FilterPolicyManager.java:1151)
        at com.symantec.smg.controlcenter.messagefiltering.virus.VirusPolicyManager.updatePolicy(VirusPolicyManager.java:266)
        at com.symantec.smg.controlcenter.messagefiltering.policy.FilterPolicyManager.updatePolicy(FilterPolicyManager.java:202)
        at com.symantec.smg.controlcenter.messagefiltering.policy.FilterPolicyAction.updatePolicy(FilterPolicyAction.java:651)
        at com.symantec.smg.controlcenter.messagefiltering.virus.VirusFilterPolicyAction.editVirusPolicy(VirusFilterPolicyAction.java:309)
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
...

 

Cause

The Application Error occurs due to the lack of annotation data.

Resolution

If the rule managed to be saved in this problematic configuration then the rule will need to be deleted. While the Application Error occurs when attempting to access this problematic rule, deletion is still successful. After the problematic rule has been deleted, you can create a new rule making sure that the Annotation option remains selected.

This issue will be corrected in a future version release of the Messaging Gateway. This article will be updated once the associated version has been released.