RDP sessions are spinning without connecting
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RDP sessions are spinning without connecting

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Article ID: 378207

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Updated On:

Products

CA Privileged Access Manager (PAM)

Issue/Introduction

  • RDP sessions are spinning without connecting
  • One RDP connection was made, but immediately hung
  •  In the session logs, saw session recording errors when the RDP sessions are launched
  •  Unmounted the NFS share and were unable to remount it
  • Set session recording to operationally safe, but still could not launch RDP sessions
  • Rebooted the appliances and were able to launch RDP sessions with the NFS shares unmounted
  • When mounted the primary NFS share again, RDP sessions stopped working even whenunmounted the primary share again

Environment

PAM 4.1.5
NFS Server on NetApp/Ontap for session recording, db backup

Cause

This problem is related to NFS server on Netapp/Ontap running as pnfs.

Resolution

Problem on Storage Third Party Product Netapp/OnTap where NFS optional parameter specifies whether to enable access for pNFS for NFSv4.1. The default setting is enabled at the time of creation. Client disabled it using the command line:

vserver nfs modify -vserver <ontap server name> -v4.1-pnfs disabled

Now PAM RDP sessions are working fine to recording sucessfully as expected.
External links reference: vserver nfs modify and Enable or disable pNFS