Clarity services won't start ( insufficient JVM memory)
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Clarity services won't start ( insufficient JVM memory)

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Article ID: 378163

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Updated On:

Products

Clarity PPM On Premise Clarity PPM SaaS

Issue/Introduction

After redeploying/downgrading/migrating Clarity files, service will not start. This error is thrown in the app-system log

2024/09/23 14:51:13.283 | OpenJDK 64-Bit Server VM warning: INFO: os::commit_memory(0x0000000400000000, 17179869184, 0) failed; error='Not enough space' (errno=12)
2024/09/23 14:51:13.283 | #
2024/09/23 14:51:13.284 | # There is insufficient memory for the Java Runtime Environment to continue.
2024/09/23 14:51:13.284 | # Native memory allocation (mmap) failed to map 17179869184 bytes for committing reserved memory.
2024/09/23 14:51:13.284 | # An error report file with more information is saved as:
2024/09/23 14:51:13.284 | # $clarity/bin/hs_err_pid49762.log

 

Environment

Any Supported Clarity Releases

Cause

Not enough JVM memory to deploy the service

Resolution

  • Check what amount of JVM you have set in properties.xml for this service and then compare to OS available memory.
  • See if any Clarity or other process is running and taking resources, and address it