Cannot run program "/opt/InCharge/IP/smarts/local-am-pm-1/bin/icupkg" observed after upgrading from Smarts to TCSA
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Cannot run program "/opt/InCharge/IP/smarts/local-am-pm-1/bin/icupkg" observed after upgrading from Smarts to TCSA

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Article ID: 378108

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Updated On:

Products

VMware Telco Cloud Service Assurance

Issue/Introduction

SYMPTOMS:

  • Cannot run program "/opt/InCharge/IP/smarts/local-am-pm-1/bin/icupkg" observed after upgrading from Smarts to TCSA.
  • Unable to Start AM-PM service.
  • In AM-PM domain logs below error is observed.
MAIN_MSG-*-STDFD_ERR-stderr: java.io.IOException: Cannot run program "/opt/InCharge/IP/smarts/local-am-pm-1/bin/icupkg": error=2, No such file or directory

Environment

TCSA-2.x

Cause

Paths specified in the SM_SITEMOD as below was not accessed by Smarts Service.

'--env=SM_SITEMOD=/opt/InCharge/IP/smarts/local-am-pm-1:/opt/InCharge/IP/smarts/local' \

 

Resolution

  • Place icupkg file under the correct directory  and followed by the AM-PM service re-start.

         ex: /opt/InCharge/IP/smarts/local-am-pm-1/bin/

                                  OR

  • We can request customer to define SM_SITEMOD and SM_WRITEABLE variable in /smarts/local/runcmd_env.sh file and remove it from the service definition and check the behaviour after starting the service