No alarm "Lost uplink redundancy" and "Network uplink redundancy lost" in vCenter when LAG is configured
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No alarm "Lost uplink redundancy" and "Network uplink redundancy lost" in vCenter when LAG is configured

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Article ID: 378014

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Updated On:

Products

VMware vSphere ESXi VMware vCenter Server 7.0 VMware vCenter Server 8.0

Issue/Introduction

When LAG (link aggregation group) is configured, the alarms "Lost uplink redundancy"  and "Network uplink redundancy lost" are not triggered in vCenter if one of the uplinks is down.

Environment


VMware vSphere ESXi 7.0

VMware vSphere ESXi 8.0

vCenter Server 7.x

vCenter Server 8.x

Cause

Alarms "Lost uplink redundancy" and "Network uplink redundancy lost" are triggered when an uplink becomes link down, resulting in only one uplink left for the port or the vSwitch. A LAG is treated as an "uplink". For this case, the uplink is not a standalone uplink, instead it is a member of a LAG. When it is down, the LAG still has another uplink which is up, so the link status of the LAG is still up.
This behavior is by design.

Resolution

It is possible to create an alarm in vCenter on target type "Host" and add the following three triggers:

https://docs.vmware.com/en/VMware-vSphere/7.0/com.vmware.vsphere.monitoring.doc/GUID-F793604F-6F21-465C-A400-5C04A71FA2E2.html

esx.problem.net.lacp.lag.transition.down
esx.problem.net.lacp.uplink.fail.speed
esx.problem.net.lacp.uplink.transition.down