Kubernetes Cluster shows empty in VMware Cloud Director
search cancel

Kubernetes Cluster shows empty in VMware Cloud Director

book

Article ID: 378012

calendar_today

Updated On:

Products

VMware Cloud Director

Issue/Introduction

  • Navigate to Cloud Director Tenant UI, select More > Kubernetes Container Cluster and the cluster list shows empty.
  • Even if the user is part of "Kubernetes Cluster and Data Services Author" role, they cannot view the clusters in Kubernetes 4.x 

Environment

VMware Cloud Director 10.x 

Cause

This happens due to missing "Administrator View" permissions in the Kubernetes Cluster Author role 

Resolution

To perform Cluster Management functions, you must hold the rights of Kubernetes Cluster Author role. Additionally, you require Administrator View:
VMWARE:CAPVCDCLUSTER to view all the clusters in your organization. 

Procedure :

1 From the top navigation bar in VMware Cloud Director Provider Portal, select Administration.

2 From the left panel under Tenant Access Control, select Global Roles.

3 In the Global Roles window, select Kubernetes Cluster Author role > Edit

4. Under other > KubeClusterExtension > select the administrator view to manage the cluster functions as per screenshot below :

 

Additional Information

Reference Document : Refer to page 6 for Cluster Management Functions :

https://docs.vmware.com/en/VMware-Cloud-Director-Container-Service-Extension/4.1/VMware-Cloud-Director-Container-Service-Extension-Using-Tenant-4.1.pdf