vCenter Server upgrade failed due to Observability timeout
search cancel

vCenter Server upgrade failed due to Observability timeout

book

Article ID: 377968

calendar_today

Updated On:

Products

VMware vCenter Server

Issue/Introduction

This issue occurs during an upgrade of 7.x vCenter Server to 8.0U3.   During the Import phase of Stage 2, the Observability service will fail due to a timeout.

 

Environment

vCenter Server 8.x

Cause

From the import-upgrade-runner.log:


XXXX-XX-XXTXX:XX:XX:XXXz INFO service_manager Command '[['/bin/service-control', '--start', 'observability']]' has exit-code='1' and stdout: Operation not can
cellable. Please wait for it to finish...
Performing start operation on service observability...

stderr:  XXXX-XX-XXTXX:XX:XX:XXXz RC = 1
Stdout =
Stderr = Job for observability.service failed because a timeout was exceeded.
See "systemctl status observability.service" and "journalctl -xe" for details.

 

Resolution

In order to allow more time for Observability to start, the "StartTimout"  for Observability should be increased using the process below.

1. Deploy Stage 1 as normal but DO NOT move on to Stage 2

2. Using the managing vCenter Server or ESXi UI, open the newly deployed 8.x appliance console and login to the shell with root credentials

3. Using vi, edit the "/etc/vmware/vmware-vmon/svcCfgfiles/observability-vapi.json" and change the value of "StartTimeout" to the desired value (default is 60)

Before: "StartTimeout": 60,
After: "StartTimout": 300,

4. Save the file and then continue on with Stage 2