Virtual Analyst not finding SDM Knowledge Base Articles
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Virtual Analyst not finding SDM Knowledge Base Articles

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Article ID: 377963

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Updated On:

Products

CA Service Management - Service Desk Manager CA Service Desk Manager

Issue/Introduction

Virtual Analyst (VA) not searching and finding SDM Knowledge Base Articles. Service Point does find the articles but not VA.

ie: Entering "User Manual test1" does not provide results even if a KB Article exists with title: "Users Manual test1"

The searchMS.log does not show any call to sdm_index_kd index.

Environment

xFlow/Service Point 17.4

Cause

The customer-entered strings are not available in search_kd intent. For KD's to display in VA we need to add additional data as per their search terms to retrieve KD articles.

Resolution

1. Stop the RASA Server.
2. Navigate to data folder present in VA installed location.
3. Edit the nlu.yml file and search for search_kd 
4. Provide the content as mentioned in the examples section which VA can understand i.e [User Manual test1](search_term). 
5. Run rasa_train and rasa_run commands

Additional Information