"invalid protocol" while setting up connection parameters
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Article ID: 377927
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Updated On:
Products
Management Center - VA
Issue/Introduction
"Invalid Protocol" seen over the connection parameters on Symantec Management Center while setup a connection and trying to connect/reconnect
Issue happen for more than one device from Symantec Management Center
There was no upgrade involved of Symantec Management Center or connected devices
SSH Context Override was setup OK
No specific logs in Symantec Management Center diagnostic logs
Removing device from Symantec Management Center and adding back again did not help
Regenerating SSH keys - (config)# device-communication ssh regenerate-key did not help
Restarting Symantec Management Center services did not help
Packet capture showed correct 3-TCP Way Handshake with successful Client/Server Key Exchange including sending some of the Encrypted packet (Client/Server) where you could see a RST from Symantec Management Center
Cause
Symantec Management Center - error - "Invalid Protocol"
Packet capture flow with the RST
Resolution
Management center has been hosted on Vmware NSX servers and there was a firewall rules blocking SSH connection.