HCX Migration page stucks at "loading" when accessed with a Active Directory account
search cancel

HCX Migration page stucks at "loading" when accessed with a Active Directory account

book

Article ID: 377912

calendar_today

Updated On:

Products

VMware HCX

Issue/Introduction

Accessing HCX administrator tasks with an Active Directory account that has administrator rights in vCenter presents the following issues.

 

  • The HCX Migration page fails to load and remains stuck on the 'loading' screen.

  • Accessing the Site Pairing or Interconnect options in the HCX plugin from vCenter generates the following error:

 

Error getching Compute Profile details
Error: Unable to process HCX inventory details.

 

Environment

VMware HCX

Cause

The vsphere.local\Administrators vSphere SSO Group is added by default in the HCX Administrator role. Consequently, if an Active Directory user designated as an admin in vCenter is not a member of the 'vsphere.local\Administrators' group, they will not have 'Administrator' rights in HCX.

Resolution

Ensure that the Active Directory account is added to the "vsphere.local\Administrators" group in vCenter. 

Alternatively, a domain user group could be added from HCX admin UI page ie https://<HCX-IP>:9443, from "HCX Role Mapping" under "Configuration".