Error "Single Sign-On Redirect URL is Null" when logging in with vCenter SSO SAML
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Error "Single Sign-On Redirect URL is Null" when logging in with vCenter SSO SAML

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Article ID: 377872

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Updated On:

Products

VMware Aria Suite

Issue/Introduction

  • When selecting the SSO SAML source from the dropdown list on the Aria Operations 8.18.1 login page, it shows a red banner error "Single Sign-On Redirect URL is Null."
  • After logging in as local admin and trying to edit/modify the SSO SAML, test is successful. But when clicking on "OK" and trying to save the change, it shows the error "Insufficient user permissions to add/update authentication source".

Environment

Aria Operations 8.x

Cause

Incorrect user name and password are used in the SSO SAML configurations.

Resolution

1. Use a username and password that can log into the SSO server (vCenter).

2. Use vCenter administrator credentials as a workaround.

3. In the meantime, fix the username and password that caused the issue mentioned above by following Step 7 - Step 12 in Configure a Single Sign-On Source in VMware Aria Operations.