vSphere Web Client becomes unresponsive after upgrading the vCenter Server 8.0 Update 3b (8.0.3.00200)
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vSphere Web Client becomes unresponsive after upgrading the vCenter Server 8.0 Update 3b (8.0.3.00200)

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Article ID: 377734

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Updated On:

Products

VMware vCenter Server 8.0

Issue/Introduction

This issue can display in a variety of symptoms, which will usually occur after an extended period of idleness of the session (1-2 hours)

  • After upgrading vCenter Server to 8.0.3.00200, the vSphere client becomes unstable and session timeouts occur.
  • The loading circle indicator will continually spin.
  • Browsing the inventory may error with errors such as "You have no privileges to view this object or it is deleted"
  • When attempting to log into the client, the login button may be greyed out.
  • Authentication may fail with the following error:

An error occurred while fetching identity providers

Environment

vCenter Server 8.0.3.00200

Cause

This issue is due to a change in the default behavior of RECYCLE_FACADES within Tomcat in the release. 

Resolution

Broadcom is working towards a permanent fix for this issue.

To work around this issue, use the steps below to disable RECYCLE_FACADES.

  1. Login to the vCenter Server with SSH.

  2. Create a backup of the catalina.properties file.

    cp /usr/lib/vmware-vsphere-ui/server/conf/catalina.properties /root/catalina.properties.bak

  3. Run the following command to add a line to the end of the original catalina.properties file to disable RECYCLE_FACADES.

    echo "org.apache.catalina.connector.RECYCLE_FACADES=false" >> /usr/lib/vmware-vsphere-ui/server/conf/catalina.properties

  4. Restart the vsphere-ui service with the below command.

    service-control --restart vsphere-ui