vIDM users are redirected to the old UI after upgrading to Aria Operations 8.18
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vIDM users are redirected to the old UI after upgrading to Aria Operations 8.18

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Article ID: 377694

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Updated On:

Products

VMware Aria Suite

Issue/Introduction

  • When VIDM is configured as an authentication source in Aria Operations 8.17 and older.
  • After upgrading to Aria Operations 8.18, when authenticated as the VIDM SSO user, the UI layout is still the older version before 8.18.
  • The new UI shows as expected when logging in as the local user admin account.

Environment

Aria Operations 8.18

VIDM 3.3.7

Cause

1. The current UI version, old or new, can be identified by the URL of the landing page after login.

  • The URL for the old UI and the URL that vIDM SSO redirects to by default is;
    • Aria_Operations_FQDN/ui
  • The URL for the new UI is;
    • Aria_Operations_FQDN/vcf-operations/ui
       

2. Load balancer is being used in the environment. But the load balancer's FQDN/IP is not being used in BOTH of the following configurations:

  • Administrations > Authentication Source, locate the vIDM authentication source and click "Edit", then in the Redirect FQDN/IP field, a node's FQDN or IP is being used instead of the load balancer's FQDN or IP.
  • Administrations > Global Settings > System Settings > System Access URL, it's either blank, a node's FQDN/IP is being used, or the load balancer's  FQDN/IP.

Resolution

This issue is resolved in 8.18 Hot Fix 4

1. VMware SSO was introduced in the Aria Operations 8.18.

2. If a load balancer is being used, make sure configurations are following the documentation provided in Introduction - Load Balancer. Note: We are continuously working on improving the documentation. If you have any concerns, please submit "Content feedback and comments" at the bottom of the documentation.

3. Make sure the load balancer's FQDN/IP is being used in BOTH of the following configurations:

  • Administrations > Authentication Source, locate the vIDM authentication source and click "Edit", then in the Redirect FQDN/IP field, type the load balancer FQDN (no https://, just the FQDN, for example, www.example.com).
  • Administrations > Global Settings > System Settings > System Access URL, type in the load balancer URL: https://lb_fqdn.

4. If there is no load balancer in use, the workaround would be to use the primary node's FQDN/IP in the above settings.