Edge Node (NSX) - Kernel Panic alert appearing for Edge VM when viewed through vCenter/ESXi Direct Console User Interface to confirm status of the virtual machine.
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Edge Node (NSX) - Kernel Panic alert appearing for Edge VM when viewed through vCenter/ESXi Direct Console User Interface to confirm status of the virtual machine.

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Article ID: 377688

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Updated On:

Products

VMware NSX

Issue/Introduction

  • The functionality of the Edge node VM is showing a Kernel Panic error when reviewed inside the DCUI client accessible from vCenter.
  • What is observed from the Edge VM DCUI client console as entry in the displayed output

'[###.##########] Kernel Panic / Kernel Panic - '

  • Among the NSX syslog entries, the following @ repeated segments filled several lines:

####-##-##T##:##:##.##Z myEdgeVM NSX #### FABRIC [nsx@#### comp="nsx-edge" subcomp="datapathd" s2comp="stats" level="WARN"] Device UUID zero for rx-port: fp-eth0, ignoring
^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@
^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@

  • In the /var/log/vmkernel.log file of the ESXi host, you see entries similar to:

####-##-##T0#:##:##.###Z In(###) vmkernel: cpu##:########)Admission failure in path: host/user/vm.########:vmmanon.########

  • No core dumps generated in the Edge VM stated directory.

/var/dump

  • The ESXi host Hostd.log outputs the following message related to virtual machine specific activites (vmx) 

####-##-##T0#:##:##.###Z In(###) Hostd[#######]: [Originator@#### sub=Vimsvc.ha-eventmgr] Event 8580 : Message on [myEdgeVM] on [myESXHost] in datacenter: The CPU has been disabled by the guest operating system. Power off or reset the virtual machine.

 

Environment

VMware NSX 

Cause

This occurs when the system suddenly looses power.

Due to external contributors within the customer environment involving the NSX dependent infrastructure components - power outages or power off initiating manually.

Resolution

The issue has been observed and resolved with a manual reboot of Edge VM.