Email messages rejected with "421 4.3.1 queue is full" response
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Email messages rejected with "421 4.3.1 queue is full" response

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Article ID: 377676

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Updated On:

Products

Messaging Gateway

Issue/Introduction

Inbound email delivery is being deferred by Messaging Gateway (SMG) with the SMTP response:

421 4.3.1 queue is full

These messages are not assigned an Audit ID since they were never accepted although the deferred connection attempt is assigned an Audit ID entry for the connecting IP address.

Cause

Applications or email clients are sending email messages faster than they can be scanned by Messaging Gateway causing either the Inbound or Outbound queue to reach the upper limit on the number of queued messages. When the Inbound or Outbound queue are full, SMG will defer new message delivery attempts until there is space in the queue to accept new messages.

Resolution

Ensure that incoming emails will be dispatched to more scanners. Too many applications bound to single scanner is not recommended and will lead to queue exhaustion. In case deploying additional scanner is not possible it is advised to discuss with the developement better mail dispatching. For instance, sending mails each one minute in contrary to sending all of them at the same time.