Hardware Compatibility Validation failed on VCF 5.2 - Unable to validate vSAN ESA disk HPE NVMe PM1733a Series
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Hardware Compatibility Validation failed on VCF 5.2 - Unable to validate vSAN ESA disk HPE NVMe PM1733a Series

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Article ID: 377663

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Updated On:

Products

VMware SDDC Manager VMware vCenter Server 8.0

Issue/Introduction

Symptoms:

 

  • Unable to validate vSAN ESA disks compatibility during new cluster deployment via CloudBuilder or commissioning new host in an existing VCF deployment.

  • SDDC manager logs contains errors similar to the excerpt below:

    INFO  [c.v.e.s.c.v.ExecutionContextToValidationConverter,http-nio-0.0.0.0-9080-exec-9] Collecting processing task errors: VCF_ERROR_INTERNAL_SERVER_ERROR for validation aggregation
    INFO  [c.v.e.s.c.v.ExecutionContextToValidationConverter,http-nio-0.0.0.0-9080-exec-9] Collecting processing task errors: VCF_ERROR_INTERNAL_SERVER_ERROR for validation aggregation
    DEBUG [c.v.e.s.c.v.ExecutionContextToValidationConverter,http-nio-0.0.0.0-9080-exec-9] There are not execution errors for execution ID b6067d4f-381e-4bf4-93ad-d2f4b04a6b97
    DEBUG [c.v.e.s.c.c.e.ValidationLocalizationTools,http-nio-0.0.0.0-9080-exec-9] Cannot find message for error code NO_VSAN_ESA_CERTIFIED_DISKS
    DEBUG [c.v.e.s.c.c.e.ValidationLocalizationTools,http-nio-0.0.0.0-9080-exec-9] Cannot find message for error code NO_VSAN_ESA_CERTIFIED_DISKS
    DEBUG [c.v.e.s.c.c.e.ValidationLocalizationTools,http-nio-0.0.0.0-9080-exec-9] Cannot find message for error code NO_STORAGE_POOL_ELIGIBLE_DISKS_FOR_VSAN_ESA

  • The issue affects the vSAN ESA certified disk model HPE 7.68TB NVMe Perf RI PM1733a SSD provided by Hewlett Packard.

Environment

VMware SDDC Manager 5.2
VMware vCenter 8.0.3

Cause

This is a known issue affecting VCF 5.2.

The issue occurs as the hardware compatibility precheck is incorrectly selecting from the vSAN HCL database the model 7.68TB NVMe Perf RI PM1733a SSD provided by Hitachi that is not vSAN ESA certified.

The cause of the problem occurs as both products share in the HCL the same PCI ID and precheck selecting the first match.


Resolution

A fix to this issue has been applied to vCenter version 8.0.3b and later.
As a workaround remove the Hitachi entry from the vSAN HCL and retry the workflow.



Workaround steps:


IMPORTANT NOTE: Ensure that fresh snapshots have been taken before making any modifications.

  1. Download manually the vSAN HCL database using steps provided in KB315556. DO NOT import the file yet to the vCenter (skip step 4 in the article)

  2. Open the json.all file using a JSON editor and remove the Hitachi entry with "id": 58775. Include all the lines concerning the product that are found inside the Curly brackets.

  3. Save the file.

  4. Import the edited file to the vCenter (step 4 of KB315556).

  5. Reattempt the workflow