Server Error 500, Communication failure for new setup web agent
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Server Error 500, Communication failure for new setup web agent

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Article ID: 377638

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Updated On:

Products

CA Single Sign On Agents (SiteMinder)

Issue/Introduction

Accessing the site protected by the web agent returns 500.

500: Server Error [20-0004]

 

From the web agent trace log,

[CSmLowLevelAgent.cpp:552][IsResourceProtected][000080fe000000000029da11cd8ea7fc-1494-66e7ca30-1d94-021c56fd][*::1][][<agent name>][/][][Communication failure between SiteMinder policy server and web agent.]
[CSmProtectionManager.cpp:193][CSmProtectionManager::DoIsProtected][000080fe000000000029da11cd8ea7fc-1494-66e7ca30-1d94-021c56fd][*::1][][<agent name>][/][][LowLevelAgent returned SmFailure.]

 

From the policy server trace log,

[Sm_Az_Message.cpp:219][][][][][][][][][LogMessage:ERROR:[sm-IsAuthorized-00220] Bad s103/r3 request detected: error 'Cannot fetch agent <agent name 2>'][][][][][]

Cause

Compare the <agent name> in web agent trace log, and the <agent name 2> in the policy trace log, we can see that the 2 names are not matched.

It's a typo issue in ACO AgentName/DefaultAgentName.

Actually, when make any change on ACO and try to submit it, the adminUI should show following warning.

Resolution

Once the AgentName was updated in the ACO, the agent no longer throws error