Endpoint Protection linux agent shows "Unknown product install" error when Protection Engine is installed/upgraded
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Endpoint Protection linux agent shows "Unknown product install" error when Protection Engine is installed/upgraded

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Article ID: 377539

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Updated On:

Products

Protection Engine for Cloud Services Protection Engine for NAS Endpoint Protection

Issue/Introduction

"Unknown product install" error is thrown when Symantec Protection Engine (SPE) is fresh installed or upgraded with Symantec Endpoint Protection (SEP) is already installed.
If SEP is reinstalled after SPE installation, then the error is not displayed, however cafagent and sisipsagent services show not running after system is rebooted.

Environment

SPE 8.x, 9.2 and older

SEP 14.3 RU1 and later

Cause

If the /opt/Symantec directory is already present then, SPE installer changes or tries to modify the permissions and remove all the permissions for others and give 770 permissions recursively. 
The problem seems to be in performing it recursively rather than doing it on only the directories which SPE owns thus affecting other Symantec product directories which are part of this shared directory and impacts their functioning.

Resolution

Engineering has identified the issue and will assign the permissions only to the required directories rather than applying it recursively.
The fix will be tentatively be available in SPE 9.2.1 version.

Workaround: 
1. Uninstall SEP completely.
2. Reinstall SEP fresh
3. Do not reboot the system (as reboot will stop the cafagent and sisipsagent daemons)