Endpoint Protection linux agent shows "Unknown product install" error when Protection Engine is installed/upgraded
search cancel

Endpoint Protection linux agent shows "Unknown product install" error when Protection Engine is installed/upgraded

book

Article ID: 377539

calendar_today

Updated On:

Products

Protection Engine for Cloud Services Protection Engine for NAS Endpoint Protection

Issue/Introduction

"Unknown product install" error is thrown when Symantec Protection Engine (SPE) is fresh installed or upgraded with Symantec Endpoint Protection (SEP) is already installed.

If SEP is reinstalled after SPE installation, then the error is not displayed, however cafagent and sisipsagent services show not running after system is rebooted.

Environment

SPE 8.x, 9.2 and older

SEP 14.3 RU1 and later

Cause

If the /opt/Symantec directory is already present then, SPE installer changes or tries to modify the permissions and remove all the permissions for others and give 770 permissions recursively.

The problem seems to be in performing it recursively rather than doing it on only the directories which SPE owns thus affecting other Symantec product directories which are part of this shared directory and impacts their functioning.

Resolution

From SPE side, there are code changes done in 9.3 release to assign the permissions only to the required directories rather than applying it recursively.
Upgrade to SEP 14.4 is also required to fix this issue.

If not upgrading, workaround could be as follows:

  • Uninstall SEP completely.
  • Reinstall SEP fresh
  • Do not reboot the system (as reboot will stop the cafagent and sisipsagent daemons)

 

 

Additional Information

Impact of Endpoint Protection and Protection Engine installed on Linux system