NSX-T Global-Manager page details do not load when using vIDM/LDAP account
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NSX-T Global-Manager page details do not load when using vIDM/LDAP account

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Article ID: 377503

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Updated On:

Products

VMware NSX

Issue/Introduction

After successfully logging into Global Manager using vIDM/LDAP user:

  • Global Manager Overview/Location-Manager page does not show any information and the sync status across sites is not retrieved.
  • System overview page shows error message "Global Manager Not Available"
  • Location-Manager page shows as "Something went wrong"
  • Site drop-down box on top of screen do not populate to move to Local Manager (LM) site.

Environment

VMware NSX 4.1.1.0.1

Cause

When using an NSX user, the request header is less than 8k in size, which is the default value that the server accepts, hence the server is able to accept the request and responds with a 200 HTTP response code.

When using an LDAP user, the request header is greater than 8k in size, which prevents the server from accepting this request and responds with a 400 HTTP response code.

However, when logging in with the "admin" account, the pages load and populate with any issues.

On Global Manager, in /var/log/gmanager/gmanager_ui.log, following entries are seen:

comp="global-manager"level="INFO"reqId="##################################"subcomp="global-manager" username="################"] {"user":"################","message":"Api Errors->","messageData":{"headers":{"normalizedNames":{},"lazyUpdate":null},"status":400,"statusText":"Bad Request","url":"https://################/api/v1/sites/self","ok":false,"name":"HttpErrorResponse","message":"Http failure response for https://nsx-gm-vip.afp.le/api/v1/sites/self: 400 Bad Request","error":"<!doctype html><html lang="en"><head><title>HTTP Status 400 ? Bad Request</title><style type="text/css">body {font-family:Tahoma,Arial,sans-serif;} h1, h2, h3, b {color:white;background-color:#525D76;} h1{font-size:22px;} h2{font-size:16px;} h3 {font-size:14px;} p {font-size:12px;} a {color:black;}.line {height:1px;background-color:#525D76;border:none;}</style></head><body><h1>HTTP Status 400 ? Bad Request</h1></body></html>"},"level":"Error","browser":"Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:84.0) Gecko/20100101 Firefox/84.0","time":"","location":"/app/system/home/gmsystemoverview/home/overview"}
comp="global-manager"level="INFO"reqId="##################################"subcomp="global-manager"username="################"] {"user":"################","message":"No module with path: disaster-recovery-wiz/:location/:is-location-evacuated found.","messageData":"getDynamicRoutesForModuleByPath","level":"Warn","browser":"Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:84.0)Gecko/20100101 Firefox/84.0","time":"Thu Aug 24 2023 10:55:59 GMT+1000 (Australian Eastern Standard Time)","location":"/app/system/home/location-manager/home"}

Resolution

Open an SR with Broadcom support and provide relevant data below:

If you are contacting Broadcom support about this issue, please provide the following:

  1. NSX Global Manager log bundles
  2. Ensure log date range covers the full date of the event(s) being investigated. When in doubt, retrieve logs for all time.
  3. Text of any error messages seen in NSX GUI or command lines pertinent to the investigation

Handling Log Bundles for offline review with Broadcom support:

Collect Support Bundles for Troubleshooting NSX-T

Uploading Diagnostic information for VMware through the Secure FTP & Broadcom portal

Creating and managing Broadcom support cases

Additional Information