User’s are unable to activate their accounts from the Windows change password screen it seems to be a jsession issue
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User’s are unable to activate their accounts from the Windows change password screen it seems to be a jsession issue

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Article ID: 377456

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Updated On:

Products

CA Identity Manager

Issue/Introduction

We have a major issue with New User Account Activation in UT, UA, and OT. User’s are unable to activate their accounts from the Windows change password screen. The automated tests run the test for this task from Edge but do not use a fresh browser session. When using an existing session with SiteMinder cookies (I think) the task works without issue which is why the tests passed. If a brand new session is started to run the task from Edge, the user will be sent directly to the logout screen after entering their User Id and PRI and pressing enter. The user will be sent back to the Windows change password screen when performing the task from the Windows change password screen.

it seems that jsessions are being invalidated or lost

Cause

Jessions are post-pended with the jboss node ID

Trying to find the node name set in UT, this returns for both servers in the standalone configuration file.
<subsystem xmlns="urn:jboss:domain:undertow:8.0" instance-id="idm-####" statistics-enabled="true">

Resolution

While the SI environment has a different config on each of instance-ids the IM nodes they are set properly.

The most likely cause for this issue is that the standalone-ha-full.xml was copied from one server and moved to the other and this setting was missed in the UT environment.