When attempting to back up the vCenter Server Appliance (VCSA) using the vCenter Server Appliance Management Interface (VAMI), the backup fails with the error message "Backup Manager encountered an exception."
search cancel

When attempting to back up the vCenter Server Appliance (VCSA) using the vCenter Server Appliance Management Interface (VAMI), the backup fails with the error message "Backup Manager encountered an exception."

book

Article ID: 377419

calendar_today

Updated On:

Products

VMware vCenter Server

Issue/Introduction

Both scheduled and manual backups of the vCenter Server Appliance (VCSA) utilizing the SMB protocol fail with the error message "Backup Manager encountered an exception."

/var/log/vmware/applmgmt/backup.log states similar snippets:

yyyy-mm-dd hh:mm:ss [xxxxxxxx-xxxxx-xxxxxxxx] [MainProcess:PID-49334] [BackupManager::Cleanup:BackupManager.py:426] INFO: Cleaning up failed backup files.

yyyy-mm-dd hh:mm:ss [xxxxxxxx-xxxxx-xxxxxxxx] [MainProcess:PID-49334] [SMBClientStorageIOLib::_run_cmd:SMBClientStorageIOLib.py:23] INFO: Running Command: ['/usr/bin/smbclient', '//share01/Software/', '-A', '/dev/shm/smbCredentialFile......', '-t', '140', '-c', 'deltree VMWARE/vCenter/vcsa.example.local/S_7.0.3.02000_20240813-230005_']
yyyy-mm-dd hh:mm:ss [xxxxxxxx-xxxxx-xxxxxxxx] [MainProcess:PID-49334] [SMBClientStorageIOLib::_process_cmd_output:SMBClientStorageIOLib.py:97] ERROR: Command failed with error: NT_STATUS_SHARING_VIOLATION
yyyy-mm-dd hh:mm:ss [xxxxxxxx-xxxxx-xxxxxxxx] [MainProcess:PID-49334] [SMBClientStorageIOLib::_process_cmd_output:SMBClientStorageIOLib.py:104] ERROR: smb cmd failed. RC: 1, Err: , Cmd: ['/usr/bin/smbclient', '//share01/Software/', '-A', '/dev/shm/smbCredentialFile.....', '-t', '140', '-c', 'deltree VMWARE/vCenter/vcsa.example.local/S_7.0.3.02000_20240813-230005_']
yyyy-mm-dd hh:mm:ss [xxxxxxxx-xxxxx-xxxxxxxx] [MainProcess:PID-49334] [BackupManager::Cleanup:BackupManager.py:430] WARNING: Ignore to clean up failed backup files, due to issue: 'Plugin error occurred. ErrCode: 5, Args: ()'.
yyyy-mm-dd hh:mm:ss [xxxxxxxx-xxxxx-xxxxxxxx] [MainProcess:PID-49334] [BackupManager::HandleBackupCleanup:BackupManager.py:474] ERROR: Failed to cleanup the backup job. Error: Failed to clean up the backup job.
yyyy-mm-dd hh:mm:ss [xxxxxxxx-xxxxx-xxxxxxxx] [MainProcess:PID-49334] [vpxdevent_lib::dispatch_events:vpxdevent_lib.py:275] INFO: Event com.vmware.applmgmt.backup.job.failed.event successfully posted to http://localhost:8085/sdk
yyyy-mm-dd hh:mm:ss [xxxxxxxx-xxxxx-xxxxxxxx] [MainProcess:PID-49334] [BackupManager::main:BackupManager.py:615] INFO: Backup job failed.
yyyy-mm-dd hh:mm:ss [xxxxxxxx-xxxxx-xxxxxxxx] [StatsMonitorDBBackup:PID-49446] [Proc::GetProcsStatus:Proc.py:361] ERROR: rc: 0, stderr: b'putting file - as \\VMWARE\\vCenter\\vcsa.example.local\\S_7.0.3.02000_20240813-230005_\\statsmonitor_db_backup.gz (1519.2 kb/s) (average 1519.2 kb/s)\n'
yyyy-mm-dd hh:mm:ss [xxxxxxxx-xxxxx-xxxxxxxx] [StatsMonitorDBBackup:PID-49446] [StatsMonitorDB::BackupStatsMonitorDB:StatsMonitorDB.py:117] INFO: Completed backup appliance stats monitor SQLite DB.
yyyy-mm-dd hh:mm:ss [xxxxxxxx-xxxxx-xxxxxxxx] [ComponentScriptsBackup:PID-49443] [Proc::GetProcsStatus:Proc.py:361] ERROR: rc: 0, stderr: b'putting file - as \\VMWARE\\vCenter\\vcsa.example.local\\S_7.0.3.02000_20240813-230005_\\vum.gz (6467.5 kb/s) (average 6467.5 kb/s)\n'

Environment

VMware vCenter Server 7.x

VMware vCenter Server 8.x

Cause

  • The "NT_STATUS_SHARING_VIOLATION" error clearly suggests that the problem stems from a mismatch in permissions.

  • The SMB server is responsible for managing access to the shared resources. If the permissions aren't configured correctly, the user account configured in vCenter Server to access the NFS/SMB share won't be able to write to the share.

 

Resolution

Verify SMB Share Permissions:

    • VCSA User Permissions:
      • Confirm the user account configured in vCenter Server to access the NFS/SMB share has write permissions to the SMB share. This can be done through the SMB server's management interface.
      • If the user account configured in vCenter Server to access the NFS/SMB share is a standard account, ensure it's not a "guest" account with limited permissions.
      • Verify that the user account configured in vCenter Server to access the NFS/SMB share is using the correct user credentials to access the share, as incorrect credentials could also lead to permission errors.

    • SMB Share Permissions:
      • Check the SMB share's permissions. Ensure they are set to allow write access to the user account configured in vCenter Server to access the NFS/SMB share.

    • Contact the vendor responsible for the SMB share to verify file permissions and ensure they allow the user to write to the specified share/path.

    • A potential starting point for investigation could be the following - SMB crediting_NETAPP 

Additional Information

If the issue persists please consider contacting Broadcom Support for further assistance.