PARITY_SERVER_ERROR When Renaming or Adding a New Policy
search cancel

PARITY_SERVER_ERROR When Renaming or Adding a New Policy

book

Article ID: 377249

calendar_today

Updated On:

Products

Carbon Black App Control (formerly Cb Protection)

Issue/Introduction

  • When attempting to create or modify an existing Policy the status at the top shows the error:
    PARITY_SERVER_ERROR
  • High Debug Logs for ServerLog-TIMESTAMP.bt9 similar to:
    processing Soap response : EditHostGroup
    HostGroupStorage::EditHostGroup() - Hostgroup name is not unique in cache.
    SOAP error on host 0 (127.0.0.1) in das__EditHostGroup [PARITY_SERVER_ERROR]
    127.0.0.1 - EditHostGroup soap fault, retVal=12
    EditHostGroup params: hostgroupedit=0x00864C00 hostgrouphandle=XX 
    processed Soap response : EditHostGroup

Environment

  • App Control Server: All Supported Versions

Cause

A deleted Policy with an identical name still exists and is referenced by one or more Agents or other tables in the database.

Resolution

Manually rename the deleted Policy in the das database.

  1. Take a full database backup.
  2. Temporarily stop the App Control Server and App Control Reporter services.
  3. Run SQL Server Management Studio as the Carbon Black Service Account.
  4. Execute the following query to confirm the presence of a Deleted Policy with an identical name, example: Desktops - HE
    use das;
    SELECT host_group_id, name, date_modified, deleted FROM dbo.host_groups (NOLOCK) WHERE name LIKE '%Desktops - HE%' AND deleted = 1;
  5. Note the relevant host_group_id and specify it accordingly, example: 16
    use das;
    update dbo.host_groups set name = 'Desktops - HE DELETED' where host_group_id = 16;
  6. Execute the query from Step 4 to confirm the Policy's name has changed.
  7. Start the Server and Reporter services.
  8. Log in to the Console and attempt to change the Policy's name once more.