Node pool stuck in processing state with error [OSCustomizationFailed]
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Node pool stuck in processing state with error [OSCustomizationFailed]

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Article ID: 377201

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Updated On:

Products

VMware Telco Cloud Automation

Issue/Introduction

In TCA-Manager UI, Node pool is stuck in processing state.

Below errors can be seen from the app logs:


Error: [OSCustomizationFailed] vmconfig status is Normal, nodeconfig status is Failed.nodeconfig failed: [{Plugin sriovdp is in Waiting stage, reason: waiting for dpdk binding finished, lastError: }{Plugin packages is in Failed stage, reason: pciutils==3.6.2-1.ph3 package not found or not installedError(1011) : No matching packages, lastError: exit status 243}{Plugin kernelMods is in Waiting stage, reason: waiting for status of plugin kernelType become Normal, lastError: }{Plugin dpdkBind is in Waiting stage, reason: waiting for status of plugin kernelMods become Normal, lastError: }{Plugin kernelType is in Waiting stage, reason: waiting for status of plugin packages become Normal, lastError: }]

Upgrade done from TCA 2.3 to TCA 3.1
This error is faced during the node pool customization done during the CNF configuration. 

Environment

3.1

Cause

During the ​node customisation it is looking for the package pciutils==3.6.2-1.ph3 which is not available, due to which the customisation is still in processing state.

There can be the below cause:

  • Old csar is used which is only compatible with photon3. 
  • Network Functions are not upgraded with the compatible version.

 

Resolution

From the TCA side, Please make sure that according to the upgrade procedure it is mentioned to update the CNFs before upgrading the node pools to 1.27 .
Upgrade Network Function before upgrading the workload cluster to v1.27.8

Note:  Upgrade Network Function to the version that is compatible with both Photon 3 and Photon 5 before upgrading the workload cluster to v1.27.8 to avoid node customisation failure and network downtime during cluster upgrading.

Also please verify that the updated CSAR is used by the vendor with the compatible versions. All of this is managed through the CSAR.