Not receiving notification alert emails from Endpoint Protection Manager
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Not receiving notification alert emails from Endpoint Protection Manager

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Article ID: 377181

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Updated On:

Products

Endpoint Protection

Issue/Introduction

After upgrading from 14.3 RU7 to 14.3 RU9 notification alert emails from Symantec Endpoint Protection Manager (SEPM) are not received.
Test email is received if triggered from the SEPM. The same behavior is with Scheduled Reports.

The SEPM console will show many errors like "You cannot access this server from this IP address" and "The administrator's user name or password is incorrect. Type a valid user name or password".

You may see below exceptions in scm-server logs

2024-08-23 11:32:04.160 THREAD 27 SEVERE: You cannot access this server from this IP address. in: java.util.logging.Level
com.sygate.scm.server.util.ServerException: You cannot access this server from this IP address.
 at com.sygate.scm.server.consolemanager.SRAuthenticator.authenticate(SRAuthenticator.java:99)
 at com.sygate.scm.server.consolemanager.requesthandler.LoginHandler.doLogin(LoginHandler.java:876)
 at com.sygate.scm.server.consolemanager.requesthandler.LoginHandler.getCredential(LoginHandler.java:271)
 at com.sygate.scm.server.consolemanager.requesthandler.LoginHandler.handleRequest(LoginHandler.java:187)
 at com.sygate.scm.server.consolemanager.RequestHandler.handleRequest(RequestHandler.java:355)
 at com.sygate.scm.server.consolemanager.RequestHandler.<init>(RequestHandler.java:171)
 at com.sygate.scm.server.servlet.ConsoleServlet.doPost(ConsoleServlet.java:151)

There are other exceptions as below repeated in the log even though user is able to login to the SEPM: This exception is related to the notification issue. 

2024-08-23 11:32:04.165 THREAD 63 SEVERE: The administrator's user name or password is incorrect. Type a valid user name or password. in: com.sygate.scm.server.task.ScheduledReportingTask
com.sygate.scm.server.util.ServerException: The administrator's user name or password is incorrect. Type a valid user name or password.
 at com.sygate.scm.server.task.ScheduledReportingHelper.doReportingLogin(ScheduledReportingHelper.java:558)
 at com.sygate.scm.server.task.ScheduledReportingTask.execute(ScheduledReportingTask.java:462)
 at com.sygate.scm.server.task.MonitoredTimerTask.run(MonitoredTimerTask.java:56)
 at java.base/java.util.TimerThread.mainLoop(Timer.java:556)
 at java.base/java.util.TimerThread.run(Timer.java:506)
2024-09-04 16:17:57.290 THREAD 25 WARNING: Session ID NOT found hence returning...
2024-09-04 16:17:57.295 THREAD 62 SEVERE: Unexpected parameter value. in: com.sygate.scm.server.task.ScheduledReportingTask
com.sygate.scm.server.util.ServerException: Unexpected parameter value.
    at com.sygate.scm.server.task.ScheduledReportingHelper.getForm(ScheduledReportingHelper.java:360)
    at com.sygate.scm.server.task.ScheduledReportingTask.generateReport(ScheduledReportingTask.java:596)
    at com.sygate.scm.server.task.ScheduledReportingTask.execute(ScheduledReportingTask.java:466)
    at com.sygate.scm.server.task.MonitoredTimerTask.run(MonitoredTimerTask.java:56)
    at java.base/java.util.TimerThread.mainLoop(Timer.java:556)
    at java.base/java.util.TimerThread.run(Timer.java:506)

Cause

Since 14.3 RU9, some customers with multiple NICs are experiencing problems with the reporting component.
You will notice few NICs are enabled but not connected.

Resolution

Identify the number of NICs installed on the system.
Check and disable the NICs which are in "Not Connected" status or having 169.254.x.x IP address and disable them.

There is work in progress to change the way the component reads the IP information and fix will be in an upcoming version.