How to identify the list of agents configured to address error of incorrect agents.
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How to identify the list of agents configured to address error of incorrect agents.

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Article ID: 377179

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Updated On:

Products

CA Process Automation Base

Issue/Introduction

Client encounter error on c20.log file related to incorrect agents, Requested for remediation steps. 

Environment

CA ITPAM 4.4.

Cause

2024-07-18 09:51:27,738 ERROR [com.optinuity.c2o.c2oserver.ServerManager] [_autoTPRecovery] Agent with id : 56659261-5591-4dd8-8337-448038a17e0f is not reachable
com.optinuity.c2o.util.C2OException: Unidentified UUID while resolving node
    at com.optinuity.c2o.transport.Resolver.getNodeURL(Resolver.java:417) ~[c2otransport-snapshot.jar!/:04.3.05.580CP08]
    at com.optinuity.c2o.c2oserver.ServerManager.initiateAutomaticTouchpointRecovery(ServerManager.java:4981) [c2oserver-snapshot.jar!/:04.3.05.580CP08]
    at com.optinuity.c2o.c2oserver.ServerManager.access$400(ServerManager.java:253) [c2oserver-snapshot.jar!/:04.3.05.580CP08]
    at com.optinuity.c2o.c2oserver.ServerManager$6.run(ServerManager.java:1464) [c2oserver-snapshot.jar!/:04.3.05.580CP08]
    at java.util.TimerThread.mainLoop(Timer.java:555) [?:1.8.0_202]
    at java.util.TimerThread.run(Timer.java:505) [?:1.8.0_202]

Resolution

1: Find the list of agents which are not in use. 
   select AgentsToRecover from Orchestrator

2: To update the incorrect agent details: 
    update Orchestrator set AgentsToRecover='<?xml version="1.0" encoding="UTF-8"?> <arrayWrapper/>'

( Please take a backup of  Orchestrator table, Engage Support for further assistance).