Reset NSX Upgrade Prechecks
search cancel

Reset NSX Upgrade Prechecks

book

Article ID: 377140

calendar_today

Updated On:

Products

VMware NSX-T Data Center VMware NSX

Issue/Introduction

  • Precheck errors were displayed initially
  • Precheck errors have since been resolved
  • A re-run of the prechecks does not resolve the issue
  • The upgrade tab was in stuck status and not able to trigger "CHECK UPGRADE READINESS".

Environment

VMware NSX-T Data Center

VMware NSX

Cause

The Upgrade plan updates a file that persists after a reboot. The plan needs to be reset via API.

Resolution

Reset the upgrade plan via API.

You can run this API call from a client such as Postman or from the root shell of any NSX manager using curl.

POST https://<mgr_IP>/api/v1/upgrade/plan?action=reset&component_type=<component>

Component parameters are: 'HOST', 'EDGE' or 'MP'

  1. POST https://<mgr_IP>/api/v1/upgrade/plan?action=reset&component_type=MP
  2. POST https://<mgr_IP>/api/v1/upgrade/plan?action=reset&component_type=EDGE
  3. POST https://<mgr_IP>/api/v1/upgrade/plan?action=reset&component_type=HOST

 

NOTE:

Check to make sure the Upgrade-Coordinator service is running before and after running the above API calls. 

Additional Information

If you are running NSX 4.1.0.2 There may be a failure to reset the upgrade plan via API. 

Please see Failed to execute method GetRemoteRepoSyncResult error when upgrading NSX

For the case where Upgrade tab was in stuck status, the user needs to logout and login again on NSX Manager UI after the API calls,