Can’t retrieve Config Server logs when using Spring Cloud Services (SCS) 3.2.5
search cancel

Can’t retrieve Config Server logs when using Spring Cloud Services (SCS) 3.2.5

book

Article ID: 377118

calendar_today

Updated On:

Products

VMware Tanzu Application Service VMware Spring Runtime VMware Tanzu Spring Runtime - SM VMware Tanzu Spring Runtime Support Only for Spring

Issue/Introduction

Spring Cloud Services provides access to the logs generated by each service instance, including logs for the backing apps (Spring Cloud Config server app or Spring Cloud Netflix Eureka app) for each instance. You can view these logs using the Service Instance Logging cf CLI plug-in. You can use the service-logs command to tail logs or dump recent logs for a service instance using the commands shown below.

To tail logs for a service instance, run cf service-logs SERVICE_NAME, where SERVICE_NAME is the name of the service instance:

 
$ cf service-logs my-config-server

 

To dump recent logs for the instance, use the --recent flag:

 
$ cf service-logs --recent my-config-server

 

If your TAS deployment uses a self-signed certificate, you must use the --skip-ssl-validation flag to deactivate the default validation of the platform's SSL certificate:

 
$ cf service-logs --skip-ssl-validation my-config-server

 

Cause

When SCS 3.2.5 is in use, retrieving service instance logs fails with the following error:

% cf service-logs config --recent
Retrieving logs for service instance config in org abc / space 123 as admin...
FAILED
/v2/services did not contain a service instance logs endpoint: maybe the broker version is too old

The error is caused by an unsupported plugin in the Spring Cloud App Broker

Resolution