System Error - Health report generation failed
search cancel

System Error - Health report generation failed

book

Article ID: 377111

calendar_today

Updated On:

Products

Clarity PPM On Premise

Issue/Introduction

Clarity Health report errors while generating two sections:

  • Summary 
  • Data warehouse

 "System Error - Health report generation failed

The other health report tabs are generating correctly.

App-ca.log messages:

com.ca.ppm.nmc.healthreport.providers.DBHealthReportProvider.getDatabaseTablespaceProperties(DBHealthReportProvider.java:394)
    at com.ca.ppm.nmc.healthreport.providers.DWHDBHealthReportProvider.addHealthReportProperties(DWHDBHealthReportProvider.java:80)
    at com.ca.ppm.nmc.healthreport.providers.DWHDBHealthReportProvider.getHealthReport(DWHDBHealthReportProvider.java:46)
    at com.ca.ppm.nmc.healthreport.providers.SummaryHealthReportProvider.addHealthReportProperties(SummaryHealthReportProvider.java:44)
    at com.ca.ppm.nmc.healthreport.providers.SummaryHealthReportProvider.getHealthReport(SummaryHealthReportProvider.java:29)
    at com.ca.ppm.nmc.healthreport.utils.HealthReportUtil.getHealthReport(HealthReportUtil.java:691)

Environment

Clarity 16.2.2

Cause

The timezones of the Clarity application server and Database servers do not match. Validated by running direct queries against DB and checking the default timezone of the Clarity app server. 

Resolution

  • DBA team updates the Clarity and Data warehouse DB timezones to match that of the Clarity server
  • Restart clarity services