Unable to login in the Provider and Tenant portal after upgrading Cloud Director 10.5.1.1
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Unable to login in the Provider and Tenant portal after upgrading Cloud Director 10.5.1.1

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Article ID: 377108

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Updated On:

Products

VMware Cloud Director

Issue/Introduction

  • unable to log in to VCD after upgrade to 10.5.1.1
  • Viewing the Console Browser Logs (F12), you see API Calls failing during the login
  • Cloud Director API Requests using the /cloudapi/ API fail with "500 Server Error"
  • Cloud Director debug logs shows the error "500 response header too large"

Environment

VMware Cloud Director 10.5.1.1

Cause

During an upgrade, it is possible that the vcloud.http.responseHeaderMax may be set to a value of zero or a very low number and can either due to an incorrect modification or an issue during the upgrade process.

Resolution

To resolve the issue, you can  Edit the Cloud Director global.properties on each cell to a high value with following steps:

1) modify the /opt/vmware/vcloud-director/etc/global.properties file by adding the entry:

  vcloud.http.responseHeaderMax=1048576

.2) restart the VCD service with the command:

     systemctl restart vmware-vcd.service

3) to verify that the VCD services successfully restarted:

    tail -f /opt/vmware/vcloud-director/logs/cell.log

4) then repeat step 1, 2 and 3 on another cell