Unable to create new clusters on NSX network segment
search cancel

Unable to create new clusters on NSX network segment

book

Article ID: 377010

calendar_today

Updated On:

Products

VMware Telco Cloud Platform Advanced VMware Telco Cloud Platform Essentials VMware Telco Cloud Platform RAN VMware Telco Cloud Platform Essentials for RAN VMware Telco Cloud Platform - 5G Edition

Issue/Introduction

Cluster creation hangs in Telco Cloud Automation (TCA) and never completes, but does not fail.

In the /common/logs/admin/app.log you see messages such as:

"message":"node has no IP addresses","reason":"MachineNoIPAddress"

Environment

2.x

3.x

Cause

Misconfigurations of the underlying network such as insufficient IP ranges can result in newly deployed nodes failing to have an IP assigned, causing the creation to hang until IPs are available for assignment.

Resolution

Ensure the underlying network segment is properly configured and the subnet has sufficient IPs available for newly created nodes.