Scheduled exports fail to be delivered
search cancel

Scheduled exports fail to be delivered

book

Article ID: 377004

calendar_today

Updated On:

Products

Information Centric Analytics

Issue/Introduction

Scheduled exports of dashboards and reports are not delivered. These may be newly scheduled or previously scheduled exports that had been working as expected.

The following error may be present in the Risk Fabric application server log (w3wp_RiskFabric.<yyyyMMdd>.log) with a timestamp corresponding to the time the export was scheduled to run:

[43:ERROR] An error occurred while exporting
System.IO.FileNotFoundException: Failed to launch chrome! path to executable does not exist
File name: 'C:\Windows\TEMP\Win64-594312\chrome-win\chrome.exe'
    at PuppeteerSharp.Launcher.GetOrFetchChromeExecutable(LaunchOptions options)
    at PuppeteerSharp.Launcher.<LaunchAsync>d__7.MoveNext()
--- End of stack trace from previous location where exception was thrown ---

The Risk Fabric application server log is located in the following path on the server hosting Internet Information Services (IIS) and the Information Centric Analytics (ICA) application:

%SystemDrive%\ProgramData\BayDynamics\Logs

An inspection of the path specified in the error message shows the folder C:\Windows\Temp\Win64-594312\chrome-win is extant on the application server but some or all of its contents are missing, including chrome.exe.

NOTE: The instance of Chrome used by the export process is distinct from and independent of any instances of Chrome you may have installed on your server. Moreover, even if Chrome has never been installed on the application server, the export process will create an instance in the Windows Temp folder for use with scheduled exports.

Environment

Version : 6.x

Component : Dashboards

Cause

ICA deploys a copy of the executable chrome.exe to the Windows Temp folder for use in rendering export content. If the path to the executable exists but the executable is missing, the export process fails silently.

The Chrome executable deployed by ICA should persist. If this problem recurs after following the steps in the Resolution section of this article, audit Windows system logs, endpoint security agent settings, and GPOs to determine the method by which this file is being deleted.

Resolution

To resolve this issue, follow this procedure:

  1. Open a command prompt (cmd.exe) as an administrator
  2. Execute the following command:
    rmdir /s /q %SystemDrive%\Windows\Temp\Win64-594312

This folder and the Chrome executable will be re-created the next time a scheduled export is generated.

Additional Information

The table dbo.ScheduledExport_TasksHistory in the RiskFabric relational database is used to log the success or failure of each step of the scheduled export process. A successful export will contain records for each of the following statuses in the Status column, in this sequence:

  1. Created
  2. Pending
  3. Started
  4. Processing
  5. Exporting
  6. Emailing
  7. Emailed
  8. Complete
  9. Purged

When the issue described in this article is present, the sequence of statuses will be truncated to the following list:

  1. Created
  2. Pending
  3. Started