External Aria Orchestrator (vRO) system with vSphere authentication shows a red error banner: "There is no valid license in the system. Check server license for details"
search cancel

External Aria Orchestrator (vRO) system with vSphere authentication shows a red error banner: "There is no valid license in the system. Check server license for details"

book

Article ID: 376880

calendar_today

Updated On:

Products

VMware Aria Suite

Issue/Introduction

  • A banner error message is showing within the UI of Orchestrator "There is no valid license in the system. Check server license for details"
  • This may be seen after upgrade of standalone Aria Orchestrator cluster to 8.16.x
  • Resetting the certificate keystore on the vRO shell does not solve the issue
    • Take snapshots and use caution with keystore commands. More info found in: vracli vro keystore -h 

Environment

VMware Aria Orchestrator 8.x

Cause

  • This may be caused by duplicate entries in the Licensing section of the vSphere Client UI, under Administration
  • Search also for unlicensed or invalid entries among the vCenter servers

Resolution

  • Remove the duplicate entries from the vSphere UI
  • Please contact vSphere Technical Support if help with this is needed.
  • They can reference the Internal Notes section in this article for a manual solution used by vSphere TS.