In Virtual Appliance Error code:3 while moving iam.jks files
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In Virtual Appliance Error code:3 while moving iam.jks files

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Article ID: 376851

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Updated On:

Products

CA Identity Manager

Issue/Introduction

During the ReportServer configuration, while performing the steps to Regenerate the Token to Authenticate JasperReports Server, we see the below error while moving iam.jks and iam.properties files to a location.

Environment

Vapp 14.5

Cause

As the root access is not available with the customer, they do see permission while editing root files

Resolution

For generating a Token to Authenticate JasperReports Server, we need to follow the steps in the document below.

https://techdocs.broadcom.com/us/en/symantec-security-software/identity-security/identity-manager/14-5/installing/Install-and-Configure-Symantec-IGA-JasperReports-Server/Regenerate-Token-to-Authenticate-JasperReports-Server.html

During step 3, we need to replace the old files with the new set of files (iam.properties & iam.jks) in the corresponding folders depending on the application server type:

JBoss:
<JBOSS_HOME>/modules/com/ca/iam/cajasper/main/
 
However, due to permission restrictions to the Virtual appliance, we see a permission denied error code 3. 
 
Workaround:

They gave me a workaround.

Instead of copying the new iam.jks file and iam.properties file to  /opt/CA/wildfly-idm/modules/com/ca/iam/cajasper,

copy them to /opt/CA/VirtualAppliance/custom/IdentityManager/keystore

and restart the IM services(restart_im)