Failed to register (SRM) VMware Live Recovery with error "method: addSolutionRole; code: 500"
search cancel

Failed to register (SRM) VMware Live Recovery with error "method: addSolutionRole; code: 500"

book

Article ID: 376702

calendar_today

Updated On:

Products

VMware Live Recovery

Issue/Introduction

  • Unable to register newly installed SRM.
  • SRM roles was migrated from old vCenter to new install of vCenter.

drconfig.log

2024-09-06T19:25:45.333Z info drconfig[01567] [SRM@6876 sub=vmomi.soapStub[36] opID=94fddc4b-fb9d-4261-87c0-84801f130913-configure:bf39] SOAP request returned HTTP failure; <SSL(<io_obj p:0x00007f0a58002cd0, h:30, <TCP 'X.X.X.X: 59638'>, <TCP 'X.X.X.X: 443'>>), /invsvc/vmomi/sdk>, method: addSolutionRole; code: 500(Internal Server Error); fault: (dataservice.fault.AlreadyExistsFault) {

-->    faultCause = (vmodl.MethodFault) null,
-->    faultMessage = <unset>
-->    msg = "Received SOAP response fault from [<SSL(<io_obj p:0x00007f0a58002cd0, h:30, <TCP 'X.X.X.X: 59638'>, <TCP 'X.X.X.X : 443'>>), /invsvc/vmomi/sdk>]: addSolutionRole
--> "
--> }
2024-09-06T19:25:45.334Z warning drconfig[01567] [SRM@6876 sub=LocalRegistrationManager opID=94fddc4b-fb9d-4261-87c0-84801f130913-configure:bf39] Failed to add role 'SrmAdministrator' id = 1101:
--> (dataservice.fault.AlreadyExistsFault) {
-->    faultCause = (vmodl.MethodFault) null,
-->    faultMessage = <unset>
-->    msg = "Received SOAP response fault from [<SSL(<io_obj p:0x00007f0a58002cd0, h:30, <TCP 'X.X.X.X : 59638'>, <TCP 'X.X.X.X : 443'>>), /invsvc/vmomi/sdk>]: addSolutionRole

Environment

VMware Live Recovery 9.X

Cause

  • The previous SRM user roles were conflicting with the newly installed SRM system, which attempted to create identical roles and failed due to their existing presence.
  • Importing and exporting default roles are not supported, as this process may result in conflicts with new role IDs that are hardcoded.

Resolution

Deleted all SRM related roles under VSPHERE.LOCAL and re-configured the SRM.

Additional Information

Please ensure that you take a complete backup of all vCenters prior to implementing any changes.