URT failure due to non-bmp characters in policies and DI
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URT failure due to non-bmp characters in policies and DI

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Article ID: 376674

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Updated On:

Products

Data Loss Prevention

Issue/Introduction

URT failure due to non-bmp characters in policies and DI

URT error:

Start: Non-BMP Validation - YEAR-MN-DAY
    *** ERROR ***
    The following table lists policies, rules, conditions, or data identifiers that
    contain unsupported non-BMP characters.
    See "Finding Non-BMP Unicode Characters in Policies" at the latest version of
    the Symantec Data Loss Prevention Help Center for additional information.
*** Detection Rule: Regex ***
    Policy Name      Policy ID Rule Name Pattern
    ---------------------------------------- ---------- ---------------------------------------- ----------------------------------------
   Policy Name       xx  Policy example and Separator ID & xx(?i)\b(?:text)

Cause

Non-bmp characters are not supported in policy and data identifiiers and will cause failures in URT results. 

see: Handling Non-BMP Unicode Characters in Data Loss Prevention

 

Resolution

In the URT report will list all the policies that have non-bmp characters to be removed before running URT again. 

see: Finding Non-BMP Characters with URT

Additional Information

NOTE: once you remove the non-bmp characters the Enforce UI will block adding those non-bmp characters back in the UI, and will be presented with an error once clicking save.