Time Slicing is slow after updating Base Calendars in Clarity
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Time Slicing is slow after updating Base Calendars in Clarity

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Article ID: 376668

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Updated On:

Products

Clarity PPM SaaS Clarity PPM On Premise

Issue/Introduction

Time Slicing job is running for hours and appears to be hanging, not certain if it’s processing or not as it does not complete

Environment

All Supported Clarity Releases

Cause

  • A user applied new changes in Clarity Base Calendar or multiple base calendars
  • This can be confirmed in PRCALENDAR table in the database
  • The Base Calendar controls resource availability and this is taken into the calculation for the allocation and assignment slices.
  • If this calendar is changed, the data will be triggered for a re-slice, and depending on the amount of data to be re-sliced, this can cause the job to run longer.

Resolution

  • The Time Slicing job is processing and not stalling, it's just slow running due to calendar change which is a major reslice updates.
  • Since the job is running we do not recommend cancelling it, as this will not cancel it on the backend and will not save any processing time. Our recommendation is letting it run to completion
  • Depending on amount of data, for large customers the Time Slicing job will likely going to take at least a few hours
  • There is no way to speed it up once there have been slice changes propagated by the calendar updates
  • There is not an easy way to predict how long it's going to take as it depends on amount of resliced data
  • Broadcom Support recommends to avoid updating calendars during normal business hours to prevent unexpected Time Slicing Job performance impacts that would conflict with important work activities

Additional Information

As a best practice, update the calendars after work hours to allow the Time Slicing a sufficient time to process all the changes before the next work day

Also check Time Slicing job slow performance - troubleshooting