Error 404 logged by igateway
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Error 404 logged by igateway

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Article ID: 37666

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Updated On:

Products

CA Application Performance Management Agent (APM / Wily / Introscope) INTROSCOPE SUPPORT AUTOMATION- SERVER CA Service Desk Manager - Unified Self Service CA Service Desk Manager CA Service Management - Asset Portfolio Management CA Service Management - Service Desk Manager CA Workload Automation AE - Business Agents (AutoSys) CA Workload Automation AE - Scheduler (AutoSys) Workload Automation Agent

Issue/Introduction

Symptoms

In EEM environments, the igateway.log captures the below ERROR message.

ERROR :: SponsorManager::submit :sponsor[ favicon.ico] not found and invocation returned 404 error , logged to igateway.log

Environment:

EEM 8.4, 12.x

Cause:

The reason is that all the browsers try to get favicon.ico file, if it is not provided with the homepage. This image file is used to display favicon and bookmark/website icon. Since we don't provide favicon.ico file with iTech, browsers sent a request on their own to get this file in the root directory of the Web Server. So in this case, the GET request used to go in format " http://:5250/favicon.ico". Since igateway cannot understand this format, it throws the sponsor not found error and ignores it.

Resolution:

This error can be safely ignored, does not affect the functionality of igateway and its modules.


 

Environment

Release: SAMBDL99000-3.1-Spectrum-Service Assurance Manager-Promotional Bundle
Component: