Unable to see local datastore while installing ESXI 7.0U3 on Dell PowerEdge systems
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Unable to see local datastore while installing ESXI 7.0U3 on Dell PowerEdge systems

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Article ID: 376632

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Updated On:

Products

VMware

Issue/Introduction

During the installation of ESXi 7.0U3 on a Dell PowerEdge R960 server, users may encounter an issue where the local disk is not visible. This problem is also observed in other versions, including ESXi 7.0 U3c, 8.0 U1, and 8.0 U2.

However, the local disk appears normally when using version 8.0 U3. The issue seems to be linked to the server’s RAID configuration, interrupt resource limits, and other technical aspects. 

This article outlines the environment, cause, and resolution to address the issue.

Environment

 

  • Server: Dell PowerEdge R960
  • RAID Controller: H965i Front (configured in RAID 1)
  • ESXi Versions Affected: 7.0 U3, 7.0 U3c, 8.0 U1, 8.0 U2
  • ESXi Version Working: 8.0 U3
  • Other Hardware: USB devices/external storage detected as normal
  • Firmware: All versions specified in the compatibility guide have been tested

 

Cause

This issue occurs due to an ESXi limit on interrupt resources. When PCI Passthrough devices request many interrupts to be allocated, it is possible that this limit has been reached which causes the issue.

vmkernel.log:

2024-06-14T14:20:51.491Z In(182) vmkernel: cpu120:2098126)bcm_mpi3_0000:5b:00.0: mpi3_setup_interrupts: 2821: Current msix vectors = 128, CPUs in the system = 128
2024-06-14T14:20:51.493Z Wa(180) vmkwarning: cpu120:2098126)WARNING: IntrCookie: 1458: Unable to find a free interrupt number

Reference: How to increase maxIntrCookies if default limit is reached in ESXi ? (broadcom.com)

2024-06-14T14:20:51.494Z Wa(180) vmkwarning: cpu120:2098126)WARNING: VMK_PCI: 593: 0000:5b:00.0: failed to allocate 128 MSIX interrupts
2024-06-14T14:20:51.494Z Wa(180) vmkwarning: cpu120:2098126)WARNING: bcm_mpi3_0000:5b:00.0: mpi3_setup_interrupts: 2832: failed to allocate interrupts. status=Out of resources.

Additionally, the ESXi system limit on interrupt resources, particularly concerning the ‘maxIntrCookies’ parameter, may be contributing to the failure to detect local disks.

After setting the "maxIntrCookies" to 4096, you will be able to see the local datastore and proceed with installation on it.

Once the ESXI is booted, maxIntrCookies is set to default. So, the bootbank is pointed to /tmp. You won't be able to view the local datastore in both UI/CLI.

Resolution

    • Install the system and use SHIFT+O during the procedure to set boot parameter “maxIntrCookies=4096”
    • Once the system performs the first reboot use SHIFT+O again and set the parameter “maxIntrCookies=4096” once again
    • When the boot process has been completed go to ESX Cli and use “vi /bootbank/boot.cfg” to edit the boot.cfg
    • Put the option “maxIntrCookies=4096” at the end of the kernelopt section (see screenshot)
    • Repeat the steps 3 & 4 for the /altbootbank.cfg and reboot the system
    • Check via “ls -l” if the bootbank is now located on the local datastore

  • Reboot the system and check whether the local datastore is visible across reboots

Additional Information