ESxi host vmkwarning logs "WARNING: FSS: xxxx: file inaccessible, exceeds maximum file name"
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ESxi host vmkwarning logs "WARNING: FSS: xxxx: file inaccessible, exceeds maximum file name"

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Article ID: 376620

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Updated On:

Products

VMware vSphere ESXi

Issue/Introduction

- Noticed the following logs on vmkernel and vmkwarning logs :

2024-09-02T12:13:50.113Z cpu108:2100833)WARNING: FSS: 3596: file inaccessible, exceeds maximum file name (ino/descN ##########$

2024-09-02T12:18:04.207Z cpu60:2100833)WARNING: FSS: 3596: file inaccessible, exceeds maximum file name (ino/descN ##########$

2024-09-02T12:18:04.207Z cpu60:2100833)WARNING: FSS: 3596: file inaccessible, exceeds maximum file name (ino/descN ##########$

 

 

Environment

VMware vSphere ESXi 7.x

Cause

The events are referring to non-VMware files stored on the datastore.
In this case, the events clearly point to msg files (MS Outlook exported files). 

Example folder which contains non-VMware compatible files:

[root@#############:/vmfs/volumes/Datastore/Folder]

[root@#############:/vmfs/volumes/Datastore/Folder] ls -latr

The files in question appear to come from a Windows system, which have been stored on the IMAGE datastore as a backup, but on NFS, the file name is too long. Accordingly, the warning messages are thrown.

Resolution

Either ignore the error messages or try removing the files .

-- Deleting the affected files by specifying their inode.
-- Download the folder with an affected file. It will not contain the affected file. 
-- Then delete the folder on the datastore browser
-- Upload the downloaded folder back to the datastore.   
-- Store the folders with affected files in a proper backup location and not on the shared IMAGE datastore. Then delete the folders on the IMAGE datastore.
-- In regards to option one, here is an example with a newly created file using the "touch" command:
 
1.  create a new empty file
 # touch z_test
2.  list inode + name of the new file
 # ls -i z_test
############# z_test
3. Find the file by inode number. Search only in the current directory
 # find . -inum ############# -maxdepth 1
  ./z_test
4.  Delete the file (and confirm)
 # find . -inum ############# -maxdepth 1  -exec rm -i {} \;
 # rm: remove './z_test'? y
--> This may fail because the filename is invalid.
5. Confirm that the file no longer exists:
 # find . -inum ############# -maxdepth 1
 # ls -i z_test
 # ls: z_test: No such file or directory

Additional Information

Please do not store non-VMware files on a VMware datastore. These files can cause issues on VMware side like the events in the logs due to exceeding file name length.