NSX-T Traffic Disruption on Edge Node in vSAN Environment After Network Outage is Fixed
search cancel

NSX-T Traffic Disruption on Edge Node in vSAN Environment After Network Outage is Fixed

book

Article ID: 376515

calendar_today

Updated On:

Products

VMware NSX

Issue/Introduction

  • Edge node in vSAN environment goes into read-only mode due to network outage.
  • Traffic disruption on the edge node is present after the network outage is fixed.
  • NSX Manager displays log entries:

var/log/cloudnet/nsx-ccp.log

[TIMESTAMP] INFO nsx-rpc:CCP-[CONTROLLER UUID]:user-executor-3 StubManagerImpl 826907 - [nsx@6876 comp="nsx-manager" level="INFO" subcomp="ccp"] Endpoint [TN UUID] registered, request stub

 

The most recent instance of the above log message should be followed by the below message 'Waiting for receiver full sync and the global ReSync Future to be true: [TN UUID]'.  If the below message is missing, you are experiencing the issue described in this KB::

[TIMESTAMP] INFO nsx-rpc:CCP-[CONTROLLER UUID]:common-0 StubEventsListenerImpl 826907 - [nsx@6876 comp="nsx-controller" level="INFO" subcomp="nestdb-pigeon"] Waiting for receiver full sync and the global ReSync Future to be true: [TN UUID]

Environment

VMware NSX-T Data Center 3.2.x

NSX VMware 4.x

Cause

Edge node and controller do not reconnect automatically after the network outage is fixed.  Edge node does not receive the latest configuration from the controller which leads to outages on this edge node.

Resolution

Fixed in VMware NSX 4.2