[PAM] The following loopback addresses could not be loaded
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[PAM] The following loopback addresses could not be loaded

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Article ID: 376483

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Updated On:

Products

CA Privileged Access Manager (PAM)

Issue/Introduction

When launching multiple PAM Clients, following error occurs.

Bind Failure
The following loopback addresses could not be loaded:
127.0.0.3:4433
Some Access Methods and Services may not work as expected until this error is fixed. Please contact your Systems Administrator.

Environment

All PAM versions

Cause

In this sample, TCP/UDP Service called "CA PAM" (which would listen on 127.0.0.3:4433) is associated with a target device and a policy was configured for it.

When the user logon to a PAM Client and navigate to the "Access" page, PAM Client will check for the services and start binding to their respective IP and Port.

And in this case the "CA PAM" service is configured with 443:4433 (report:local) port.

 

As second PAM Client is also trying to bind to that IP:Port, there is a conflict.

 

Resolution

In this sample, the "CA PAM" services is available Out of the Box and configured with a static Port.

If this services does not need to be used then it can be removed from the target device so the PAM Client will not bind to that 127.0.0.3:4433.

If the service is user created, then it can be configured with * as local port instead of a fixed one.

For example, 443:* (remote:local) so then the PAM Client will use ephemeral (random) port to bind and that will prevents any port conflict.