[PAM] The following loopback addresses could not be loaded
search cancel

[PAM] The following loopback addresses could not be loaded

book

Article ID: 376483

calendar_today

Updated On:

Products

CA Privileged Access Manager (PAM)

Issue/Introduction

When launching the PAM client, the following error occurs.

Bind Failure
The following loopback addresses could not be loaded:
127.0.0.3:4433
Some Access Methods and Services may not work as expected until this error is fixed. Please contact your Systems Administrator.

Cause

When a user logs into a PAM Client and navigates to the Access page, the PAM Client will check for the TCP/UDP services and start binding to their respective IPs and ports. If PAM is unable to bind to the local IP and port, then the error will occur. The most common cause for this is other software already binding to the local IP and port, but third-party software may also block PAM from binding to certain local IPs.

In this example, the TCP/UDP service called "CA PAM" is configured to listen on 127.0.0.3:4433 and is associated with a target device and a policy was configured for it. And in this case the "CA PAM" service is configured with 443:4433 (remote:local) port.

Resolution

If the TCP/UDP is configured to use a static local port, update it to an asterisk to allow PAM to bind to any available port for that local IP. If the issue still occurs with the asterisk in place, then the local IP address may need to be changed.

In this example, the "CA PAM" service is available Out of the Box and configured with a static port. The Ports field was updated from 443:4433 to 443:* and the error went away.

Additional Information

For more information, please refer to the Create TCP/UDP Services to Access a Device documentation page.