Error 401 Unauthorized occurs after saving a Cost Plan sub-object record

book

Article ID: 37648

calendar_today

Updated On:

Products

CLARITY PPM FOR ITG CLARITY PPM FEDERAL Clarity PPM On Premise

Issue/Introduction

Symptoms

When trying to save a new record for a Cost Plan sub-object, we get an error message.  When we return to the sub-object list, we see that the record was created successfully.  This error seems to occur only when we click 'Save and Return' or 'Return' button.

Steps to Reproduce:

  1. Log in to a system where there is a sub-object on the Cost Plan object
  2. Navigate to a Project, Financial Plans, and create or open existing Cost Plan
  3. From the Properties tab, select the link to open the sub-object list view
  4. Click 'New' button to create a new instance
  5. Fill in all the required fields
  6. Click 'Save' button - it saves successfully
  7. Click 'Return' button - Error
  8. Navigate back to the sub-object list view
  9. Open the existing record (just created)
  10. Click 'Save and Return' or 'Return'  

Expected Result: Navigation should return to the sub-object list view without any errors

Actual Result: Error 401 - Unauthorized. You are not authorized to view the page. If you are sure you have access, try logging in again or contact your system administrator.

Cause: 

Caused by CLRT-77411

Resolution:  

Our sustaining team reviewed CLRT-77411 and closed it as they are not planning to make any changes to this area of the product. 

Workaround: 

This issue does not interfere with the creation or modification of the data on the Cost Plan sub-object.  This issue is causing navigation problems.  Use the application navigation controls to navigate back to the list view.

Additional Information: 

For more details please review the Customer Reported Defect Resolution Policy for CA PPM  

Environment

Release: ESPCLA99000-13.3-Clarity-Extended Support Plus
Component: